vSphere 6.7 U1 und Veeam Backup 9.5 U3a

Backup Jobs scheitern nach Update auf vSphere 6.7 U1

Am 16.10.2018 wurde das Update 1 von vSphere 6.7 veröffentlicht. Dieses wurde lange erwartet, da es erstmalig den vollen Funktionsumfang des HTML5 Clients bietet. Zuvor mussten noch einige Aufgaben mit dem Web-Client (Flash) erledigt werden.

Leider stellte sich recht schnell heraus, daß es zu Problemen mit Veeam Backup kam, nachdem User ihre Cluster auf vSphere 6.7 U1 angehoben hatten.

Workaround

VMware und Veeam arbeiteten eng zusammen, um die Ursache des Problems zu finden. Es stellte sich schnell heraus, daß eine Änderung in der vSphere API zu Problemen in der Kommunikation führte.

Die aktuelle API Version ist 6.7.1, die aber nicht mit der aktuellen Veeam Version 9.5 U3a harmoniert. Laut Veeam wird mit dem in Kürze zu erwartenden Update Veeam Backup 9.5 U4 das Problem behoben sein. Für alle, die schon jetzt auf vSphere 6.7 U1 aktualisiert haben, gibt es einen Workaround. Man muss einen Registry-Key setzen, der Veeam auf die ältere API 6.7 zwingt.

Achtung! Dies ist keine empfohlene Lösung. Wer aktuell noch nicht auf vSphere 6.7 U1 ist UND Veeam Backup einsetzt, sollte das Update 4 von Veeam abwarten.

Der Workaround muss nach Installation von Veeam Backup 9.5 Update 4 wieder rückgängig gemacht weden.

HKLM\SOFTWARE\Veeam\Veeam Backup and Replication

Hier muss ein Multi-String-Value (REG_MULTI_SZ) erzeugt werden (Deutsch: „Wert der mehrteiligen Zeichenfolge“).

Im Feld „Wert“ trägt man folgende Zeichenfolge ein:

6.7.1 = 6.7

Damit wird die API 6.7 erzwungen, was möglicherweise zu anderen Problemen führen könnte. Es ermöglicht jedoch übergangsweise die Interaktion von Veeam mit vSphere.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.